Infrastructure outage

Incident Report for One eBike Cloud

Postmortem

What happened:
A misconfigured secret caused critical services to fail, leading to an outage.

Impact:
Services were unavailable from 9:45 -11:45.

Resolution:
The configuration was corrected and systems fully restored.

Next steps:
We take care that the secret reconfigurations will be automized in the future.

Posted Nov 24, 2025 - 12:10 CET

Resolved

Resolved, all component are operational again.
Posted Nov 24, 2025 - 12:04 CET

Update

Services are recovering
Posted Nov 24, 2025 - 11:48 CET

Monitoring

A fix has been implemented, the first services are recovering. We are monitoring the situation.
Posted Nov 24, 2025 - 11:44 CET

Update

We are currently attempting to restart the infrastructure, which could allow us to be online again in a ten to thirty minutes.
Posted Nov 24, 2025 - 11:34 CET

Update

We are continuing to work on a fix for this issue.
Posted Nov 24, 2025 - 10:35 CET

Identified

Due to infrastructure issues we're unable to provide our services right now. We're sorry for the inconveniency this might cause and are working on solution.
Posted Nov 24, 2025 - 10:35 CET
This incident affected: Brose E-Bike App (Brose E-Bike App API, Mobile SDK API, Authentication, Komoot Integration, Strava Integration), One E-Bike Cloud Portal (One E-Bike Cloud UI, Bike Connector API, Authentication), and Component API.